Forum

Questions and discussions

[SOLVED] Local installation - MAMP PRO - VirtualHost ?

Any questions about installation and updates

[SOLVED] Local installation - MAMP PRO - VirtualHost ?

Postby pepperstreet » Sun Dec 16, 2012 1:40 pm

(First of all, many thanks for activating my account at the weekend! ;-) )

I want to install your script on a local MAMP PRO environment. I also read another post about the issues with subdirectory installation. I thought MAMP PRO and VIRTUALHOST name should work. But I still have some issues:

- Install routine did not work for me, db tables were not created
- tried manual execution of sql dump
- issue: got no hint about the demo admin and pass
- frontend seems to work partly..., category overview and image path are fine
- slider images work fine
- issue: sub-category images do not show up
- issue: detail images do not show up
- issue: single pages/paths are not correct. still looks like SEF URL, though I set all Rewrites to OFF !?

No clue, whats going on.

(I will try another fresh MAMP/VirtualHost setup, new installation... hopefully with demo pass message ;-) )
Last edited by pepperstreet on Tue Dec 18, 2012 5:44 pm, edited 1 time in total.
pepperstreet
 
Posts: 117
Joined: Fri Dec 14, 2012 10:49 pm

Re: Local installation - MAMP PRO - VirtualHost ?

Postby admin » Mon Dec 17, 2012 11:17 am

- Install routine did not work for me, db tables were not created
- tried manual execution of sql dump
- issue: got no hint about the demo admin and pass


You should check the rights of mysql user.
/admin/function/db.php

- issue: sub-category images do not show up
- issue: detail images do not show up
- issue: single pages/paths are not correct. still looks like SEF URL, though I set all Rewrites to OFF !?


There must be .htaccess file in the root directory. Apache must support .htaccess instructions.
admin
Site Admin
 
Posts: 1458
Joined: Sun Mar 07, 2010 5:55 pm

Re: Local installation - MAMP PRO - VirtualHost ?

Postby pepperstreet » Mon Dec 17, 2012 2:08 pm

htaccess is there. Also edited the other occurrences, and turned off SEF.
DB user is o.k.

My third installation seems to work now. Got the success message and demo user hint.
Seemed to be an issue with MAMP PRO folder location and access rights?! I will post my experiences later on.
pepperstreet
 
Posts: 117
Joined: Fri Dec 14, 2012 10:49 pm


Return to Installation

Who is online

Users browsing this forum: No registered users and 2 guests

cron
  Photo Store Script

Professional php photo stock script and WordPress plug-in for photographers and video producers.

  Support
  CMSaccount Inc.