Questions and discussions


Report any problems or bugs


Postby Gregor » Tue Sep 04, 2018 5:32 pm

There is an error when you try to log in via Facebook. You can not use it.
Posts: 1
Joined: Mon Sep 03, 2018 8:27 pm

Re: Facebook

Postby admin » Wed Sep 05, 2018 5:30 am

You should configure the facebook login here:
Admin panel -> Settings -> Social networks

When you create a facebook application you have to make sure that you set a correct site URL.
If URL starts with https:// you need to use https://
If there is http:// it must be http:// too in the application.
Also the URL can be with www or without www.

It is better to write all 4 variants in the application's settings:

If you have problems you could write me an email with your site details.
Site Admin
Posts: 1462
Joined: Sun Mar 07, 2010 5:55 pm

Re: Facebook

Postby Walter » Wed Sep 05, 2018 2:54 pm

The Facebook App Review process and API permissions model have been updated. Learn More.

In order to maintain your current API access, your app will need to be submitted for review by August 1, 2018. If your app is not submitted for review, you will lose access to these permissions and features.
Posts: 13
Joined: Fri Aug 31, 2018 12:20 pm
Location: Netherlands

Re: Facebook

Postby admin » Mon Sep 10, 2018 2:33 pm

In addition, the default and email permissions are pre-approved for all apps, so they always appear here. These are the only two login permissions that do not require app review. All other login permissions and features in the app review submission interface require app review.

The default and email permissions are enough for the login by Facebook. You don't need other ones.
Site Admin
Posts: 1462
Joined: Sun Mar 07, 2010 5:55 pm

Login via Facebook

Postby mj72 » Sun Oct 20, 2019 7:30 pm

This worked for me:
Create app and follow proces
Menu "Basic":
Display Name: - facebook login (your choice)
Namespace: Empty, App Domains: and
enter Contact Email, Privacy Policy URL and Terms of Service URL
Category: Business and Pages
Business Use Support my own business
at the bottom - Site URL:

Left-menu under PRODUCTS, Facebook Login, Settings:
Client OAuth Login: Yes
Web OAuth Login: Yes
Enforce HTTPS: Yes
Force Web OAuth Reauthentification: No
Embedded Browser Login: Yes
Use Strict Mode for Redirect URls: Yes
Valid OAuth Redirect URls:
(http is no longer supported)
Click ON/Live in the top-menubar.

Copy App ID and App Secret to Admin-panel > Settings > Social Networks

But was still blank...

Admin-panel > Settings > PHP.ini: Must be minimum 5.6
Your webhost (for example bluehost) > Upgrade php to minimum 5.6

Back to my site. I opened .htaccess-file in root and deleted line 3:
# Use PHP5.6 as default
AddHandler application/x-httpd-ea-php56 .php
AddHandler application/x-httpd-eig-php52 .php
RewriteEngine on

Finally it worked :-)
Posts: 94
Joined: Sat Jan 10, 2015 10:55 am

Return to Bugs & Troubleshooting

Who is online

Users browsing this forum: No registered users and 1 guest

  Photo Store Script

Professional php photo stock script and WordPress plug-in for photographers and video producers.

  CMSaccount Inc.