Forum

Questions and discussions

When Sharing in Facebook thumbnails are not displaying

Report any problems or bugs

When Sharing in Facebook thumbnails are not displaying

Postby riahut.com » Tue Nov 22, 2011 4:34 am

When Sharing in Facebook thumbnails are not displaying, not sure if it is bug but that is the fact.
People, please confirm.
riahut.com
 
Posts: 99
Joined: Mon Aug 09, 2010 9:41 pm
Location: http://ectarphotostock.com

Re: When Sharing in Facebook thumbnails are not displaying

Postby admin » Tue Nov 22, 2011 12:20 pm

The script shares only a title and URL - not photo URL.
admin
Site Admin
 
Posts: 1462
Joined: Sun Mar 07, 2010 5:55 pm

Re: When Sharing in Facebook thumbnails are not displaying

Postby riahut.com » Tue Feb 21, 2012 4:10 pm

I think template should be redesigned to allow Facebook fetch photo. But that is custom change.
riahut.com
 
Posts: 99
Joined: Mon Aug 09, 2010 9:41 pm
Location: http://ectarphotostock.com

Re: When Sharing in Facebook thumbnails are not displaying

Postby riahut.com » Wed Feb 22, 2012 6:35 pm

I see the problem, Facebook (and other social media sites) cannot detect thumbnail because it wrapped in <iframe> I think solution will be to add hidden image for the purposes of sharing link with image thumbnail
riahut.com
 
Posts: 99
Joined: Mon Aug 09, 2010 9:41 pm
Location: http://ectarphotostock.com

Re: When Sharing in Facebook thumbnails are not displaying

Postby riahut.com » Wed Feb 22, 2012 6:40 pm

Solution is:

edit your template: item_photo.tpl

and find:
<div class="file_image">
{IMAGE}
<div class="file_links">

make it:
<div class="file_image">
<div class="imageForSharing" style='display:none'><img src="{DOWNLOADSAMPLE}"/></div>
{IMAGE}
<div class="file_links">

this will create hidden thumbnail which Google+ and Facebook will detect properly.
If anyone see any drawback please post here.
riahut.com
 
Posts: 99
Joined: Mon Aug 09, 2010 9:41 pm
Location: http://ectarphotostock.com

Re: When Sharing in Facebook thumbnails are not displaying

Postby amperial » Mon Apr 09, 2018 4:10 pm

That works with item_vector.tpl as well. But how to make it work with video and audio thumbs?
amperial
 
Posts: 11
Joined: Sat Apr 07, 2018 9:22 pm


Return to Bugs & Troubleshooting

Who is online

Users browsing this forum: No registered users and 4 guests

cron
  Photo Store Script

Professional php photo stock script and WordPress plug-in for photographers and video producers.

  Support
  CMSaccount Inc.